summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:45:41 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:46:09 -0800
commitd3eb130aefc4dba910d7b8b6e72d1d729e7e39a5 (patch)
tree3c4440866dda210979ac34cd30bc6878097a2175 /dev-python/pyparted
parentdev-python/pyparted-3.11.3: Add py38, enable tests (diff)
downloadgentoo-d3eb130aefc4dba910d7b8b6e72d1d729e7e39a5.tar.gz
gentoo-d3eb130aefc4dba910d7b8b6e72d1d729e7e39a5.tar.bz2
gentoo-d3eb130aefc4dba910d7b8b6e72d1d729e7e39a5.zip
dev-python/pyparted-999999: Add py38, enable tests
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/pyparted-999999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pyparted/pyparted-999999.ebuild b/dev-python/pyparted/pyparted-999999.ebuild
index 9a99955ada23..edc745ca9d65 100644
--- a/dev-python/pyparted/pyparted-999999.ebuild
+++ b/dev-python/pyparted/pyparted-999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,8} )
inherit distutils-r1 flag-o-matic git-r3
DESCRIPTION="Python bindings for sys-block/parted"
@@ -21,7 +21,8 @@ DEPEND="
${RDEPEND}
virtual/pkgconfig
"
-RESTRICT="test"
+
+distutils_enable_tests unittest
src_configure() {
append-cflags -fcommon