summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-28 14:35:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-28 14:48:42 +0200
commit214eecd3d653caf0b3249728ef1b14f1b23a775a (patch)
tree4c2503c004142e23269d7eb84d718a7ccf9871cc /dev-python/pytest-xdist
parentdev-python/pytest-forked: Bump to 1.3.0 (diff)
downloadgentoo-214eecd3d653caf0b3249728ef1b14f1b23a775a.tar.gz
gentoo-214eecd3d653caf0b3249728ef1b14f1b23a775a.tar.bz2
gentoo-214eecd3d653caf0b3249728ef1b14f1b23a775a.zip
dev-python/pytest-xdist: Bump to 1.34.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 5ce83b0cf452..76387d4b5ce8 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -3,3 +3,4 @@ DIST pytest-xdist-1.28.0.tar.gz 61486 BLAKE2B ef8157079ea890342cd566f327588148fa
DIST pytest-xdist-1.31.0.tar.gz 66133 BLAKE2B 79fe5f3bcad3421c1c751ffe6e09f0da42d4ff7c0016cb421ffabcab167028ec41ccfb02bbb275564cd74b13ade8d6e79bbb70b34995f3bc9000604a1533df9a SHA512 b7960d20295232b251c8ddcc5a3b9d6e7b761d577ba11c2647b4b4b410ee5c05998cf57fa57208561eb3ea7c4914db1fd446173794589d8c8e8e79ff8e0ad3aa
DIST pytest-xdist-1.32.0.tar.gz 67733 BLAKE2B da0ce4e43dc8752e4329ddcbc13a5f55f5bc120c13f39bb01916770d2dc1864197fd91f92bc55ba27cd74b0d837ac2d310980874cdf54761339b2cd654dd6e74 SHA512 f159b4653efb4afeff4124df484670d3c672e1014712f948390b25efc53096f8237258c83a5f1a9e688c52b4a756291cb731d37fdfa800707f556550a19cb0e8
DIST pytest-xdist-1.33.0.tar.gz 65588 BLAKE2B 096ffa9295ec0ef4d390b714b02a4d126aa33475b55591b91375f2da0c957802e007b990dc2051d5198f223b250a4a7294367c9da8f8969313a61a7e8ef18ebd SHA512 5e5b23e60b546779d4bbcc9b86c004bdb084689ba006c8bb8a7db9be60b6080f04a5bb2b1f5b43a5062b82e35493331d1da699d8a36177307280b06aa23a1367
+DIST pytest-xdist-1.34.0.tar.gz 66151 BLAKE2B ac5274e32b3ef6b72113efd4300eb6946a977e0e202d3383abcdbc022126b7806edb326ddc16abb1219e22eb091e06a9c39fce3031aaf5943d4ad653a47af142 SHA512 69e9877ee0268d71d7c0ca202ccc46b3ba1a9271f0e6e4ac4b76602833f9b7012364eb6924ae994e76c1d48d63adf1702d4c5e6ed5b75c52ac7ebae958210e24
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
new file mode 100644
index 000000000000..963bc520b04c
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pleaes do not depend on pytest to avoid unnecessary USEDEP enforcement
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/pytest-xdist-1.32.0-timeout.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}