summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-29 11:05:23 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-29 11:11:21 +0100
commitfc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7 (patch)
treed9000079c2ba5d4025c6d6959691ce2e6fd22119 /dev-python/pythondialog/pythondialog-3.4.0.ebuild
parentnet-misc/icaclient: Removed old. (diff)
downloadgentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.tar.gz
gentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.tar.bz2
gentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.zip
dev-python/pythondialog: version bump to 3.4.0.
This commit: * alters python-3.4.0.ebuild's slot to 0 for Python 3.x and pypy3 interpreters. * adds python-3.4.0-r200.ebuild using slot "python-2" for Python 2.7 and pypy interpreters. An EAPI 6 bump is crammed in whilst we're at it. Closes: https://bugs.gentoo.org/639188 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/pythondialog/pythondialog-3.4.0.ebuild')
-rw-r--r--dev-python/pythondialog/pythondialog-3.4.0.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/dev-python/pythondialog/pythondialog-3.4.0.ebuild b/dev-python/pythondialog/pythondialog-3.4.0.ebuild
index 35c80c28d2df..8a5f44a07b90 100644
--- a/dev-python/pythondialog/pythondialog-3.4.0.ebuild
+++ b/dev-python/pythondialog/pythondialog-3.4.0.ebuild
@@ -1,32 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python3_{4,5,6} pypy3 )
inherit distutils-r1
DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
-HOMEPAGE="http://pythondialog.sourceforge.net/ https://pypi.python.org/pypi/python2-pythondialog"
-SRC_URI="mirror://pypi/${PN:0:1}/python2-${PN}/python2-${P}.tar.gz"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
LICENSE="LGPL-2"
-SLOT="python-2"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="doc examples"
RDEPEND="dev-util/dialog"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/python2-${P}"
-
-python_prepare() {
- if python_is_python3; then
- 2to3 -w --no-diffs setup.py || die "could not convert to Python 3"
- fi
-}
-
python_prepare_all() {
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
distutils-r1_python_prepare_all
@@ -37,7 +29,7 @@ python_compile_all() {
}
python_install_all() {
- use examples && local EXAMPLES=( examples/. )
+ use examples && dodoc -r examples
use doc && local HTML_DOCS=( doc/_build/html/. )
distutils-r1_python_install_all