summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-27 14:31:02 +0100
committerJulian Ospald <hasufell@gentoo.org>2015-10-27 14:31:37 +0100
commitf89c61ff67ed9869a1071793f6e492771bd486d5 (patch)
tree9cd6c1f727ff43437fc5a39973532fd180d1fee6 /dev-python/pyuv/pyuv-1.2.0.ebuild
parentwww-servers/tomcat: generate a more secure password (diff)
downloadgentoo-f89c61ff67ed9869a1071793f6e492771bd486d5.tar.gz
gentoo-f89c61ff67ed9869a1071793f6e492771bd486d5.tar.bz2
gentoo-f89c61ff67ed9869a1071793f6e492771bd486d5.zip
dev-python/pyuv: initial import of version 1.2.0
Gentoo-Bug: 531734
Diffstat (limited to 'dev-python/pyuv/pyuv-1.2.0.ebuild')
-rw-r--r--dev-python/pyuv/pyuv-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyuv/pyuv-1.2.0.ebuild b/dev-python/pyuv/pyuv-1.2.0.ebuild
new file mode 100644
index 000000000000..ab665cacadd1
--- /dev/null
+++ b/dev-python/pyuv/pyuv-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for libuv"
+HOMEPAGE="https://pyuv.readthedocs.org/en"
+SRC_URI="https://github.com/saghul/pyuv/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# https://github.com/saghul/pyuv/blob/v1.x/setup_libuv.py#L117
+RDEPEND=">=dev-libs/libuv-1.7.3:0/1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/pyuv-pyuv-${PV}"
+
+src_configure() {
+ mydistutilsargs=( build_ext --use-system-libuv )
+ distutils-r1_src_configure
+}