summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-03 13:13:16 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-03 13:26:55 -0700
commiteb0d8c553ae4c9732596112a221c4d7348dfe9b2 (patch)
treed523f07a4fae1fd11b31ec662fdc97581451a062 /dev-python/rfc3987
parentgames-strategy/widelands: Remove old (diff)
downloadgentoo-eb0d8c553ae4c9732596112a221c4d7348dfe9b2.tar.gz
gentoo-eb0d8c553ae4c9732596112a221c4d7348dfe9b2.tar.bz2
gentoo-eb0d8c553ae4c9732596112a221c4d7348dfe9b2.zip
dev-python/rfc3987: add python3.6 and pypy to PYTHON_COMPAT
Since dev-python/regex does not compile with pypy3, and the regex module is not a hard dep, use python_gen_cond_dep to omit the dev-python/regex dependency for pypy3. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
index e21e5e9dbdae..c55109efc5e0 100644
--- a/dev-python/rfc3987/rfc3987-1.3.7.ebuild
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
inherit distutils-r1
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"