summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
index e21e5e9dbdae..c55109efc5e0 100644
--- a/dev-python/rfc3987/rfc3987-1.3.7.ebuild
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
inherit distutils-r1
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"