summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rlcompleter2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rlcompleter2')
-rw-r--r--dev-python/rlcompleter2/Manifest1
-rw-r--r--dev-python/rlcompleter2/metadata.xml8
-rw-r--r--dev-python/rlcompleter2/rlcompleter2-0.98-r1.ebuild25
-rw-r--r--dev-python/rlcompleter2/rlcompleter2-0.98.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/rlcompleter2/Manifest b/dev-python/rlcompleter2/Manifest
new file mode 100644
index 000000000000..41e086046e7a
--- /dev/null
+++ b/dev-python/rlcompleter2/Manifest
@@ -0,0 +1 @@
+DIST rlcompleter2-0.98.tar.gz 10581 SHA256 41d00709f4275af49605461cecb935eac5e1d4a39bf0c34f6e0c5a1e00304617 SHA512 577118a8e94fe71a682a1210f5b156f5fa1078ae30efb1913e4b64569adfc44c64eadb993e9180d98243975589555204ede444fdd80d9094d279ede81e9e1801 WHIRLPOOL 03f649df9419e511de417d75294fe39db0ea55a4c09398986c9c59ae93fced6fa9817a0c5f26055c1119a281fbf0355891d5de7ddbd636a361ac72c538a3c929
diff --git a/dev-python/rlcompleter2/metadata.xml b/dev-python/rlcompleter2/metadata.xml
new file mode 100644
index 000000000000..649fc1495ae0
--- /dev/null
+++ b/dev-python/rlcompleter2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">rlcompleter2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rlcompleter2/rlcompleter2-0.98-r1.ebuild b/dev-python/rlcompleter2/rlcompleter2-0.98-r1.ebuild
new file mode 100644
index 000000000000..c418f75527eb
--- /dev/null
+++ b/dev-python/rlcompleter2/rlcompleter2-0.98-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line completion"
+HOMEPAGE="http://codespeak.net/rlcompleter2/ http://pypi.python.org/pypi/rlcompleter2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_postinst() {
+ ewarn "Please read the README, and follow instructions in order to"
+ ewarn "execute and configure rlcompleter2."
+}
diff --git a/dev-python/rlcompleter2/rlcompleter2-0.98.ebuild b/dev-python/rlcompleter2/rlcompleter2-0.98.ebuild
new file mode 100644
index 000000000000..4921fcd19424
--- /dev/null
+++ b/dev-python/rlcompleter2/rlcompleter2-0.98.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Python command line completion"
+HOMEPAGE="http://codespeak.net/rlcompleter2/ http://pypi.python.org/pypi/rlcompleter2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="rlcompleter2.py"
+
+pkg_postinst() {
+ ewarn "Please read the README, and follow instructions in order to"
+ ewarn "execute and configure rlcompleter2."
+}