summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-20 12:00:44 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-20 12:29:21 +0100
commit24f3b61dbd6db8a41c01dc5ea8bd5bf4b87704b2 (patch)
tree19811acd6c4451f32f8a21bbb75c19fcad2e99b0 /dev-python/six
parentsci-visualization/pythonprop: Adopt to matplotlib USE=gtk renaming (diff)
downloadgentoo-24f3b61dbd6db8a41c01dc5ea8bd5bf4b87704b2.tar.gz
gentoo-24f3b61dbd6db8a41c01dc5ea8bd5bf4b87704b2.tar.bz2
gentoo-24f3b61dbd6db8a41c01dc5ea8bd5bf4b87704b2.zip
dev-python/six: Break if SITEDIR/six is a dir
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=546730 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 9faef64ea365..ed0c5b8e716b 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,6 +26,15 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+pkg_pretend() {
+ six_dir_check() {
+ local dir="${ROOT}"/$(python_get_sitedir)/six
+ [[ -d "${dir}" ]] \
+ && die "${PN} doesn't work if ${dir} is a directory #546730"
+ }
+ python_foreach_impl six_dir_check
+}
+
python_prepare_all() {
# https://bitbucket.org/gutworth/six/issues/139/
sed \