summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-08 11:33:08 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-08 11:33:08 -0500
commit660b793b6b704b2e3a9b3bc6e4257fb61e60bd0b (patch)
tree2c14b84168b0401fc75ea4dd1719f40a3c05ce1d /dev-python/six
parentkde-plasma: remove 5.4.2 (diff)
downloadgentoo-660b793b6b704b2e3a9b3bc6e4257fb61e60bd0b.tar.gz
gentoo-660b793b6b704b2e3a9b3bc6e4257fb61e60bd0b.tar.bz2
gentoo-660b793b6b704b2e3a9b3bc6e4257fb61e60bd0b.zip
dev-python/six: Drop pkg_pretend check for six directory
Calling python_foreach_impl from pkg_pretend currently fails if the relevent versions of dev-lang/python are not installed. pkg_pretend runs before dependencies are installed, so we can't rely on them. Package-Manager: portage-2.2.26_p10
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 2774a6298ab2..b00b76cf9777 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,25 +26,12 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
-# Run twice.
-# pkg_pretend to catch as early as possible, but be forgiving if
-# python impl is not installed allready.
-# pkg_setup to catch them all
-pkg_pretend() {
- six_dir_check() {
- type -p "${PYTHON}" > /dev/null || return 0
- local dir="${ROOT%/}$(python_get_sitedir)"/six
- [[ -d "${dir}" ]] \
- && die "${PN} doesn't work if ${dir} is a directory #546730"
- }
- python_foreach_impl six_dir_check
-}
-
pkg_setup() {
six_dir_check() {
local dir="${ROOT%/}$(python_get_sitedir)"/six
- [[ -d "${dir}" ]] \
- && die "${PN} doesn't work if ${dir} is a directory #546730"
+ if [[ -d "${dir}" ]]; then
+ die "${PN} doesn't work if ${dir} is a directory #546730"
+ fi
}
python_foreach_impl six_dir_check
}