summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-07 10:47:53 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-07 10:48:10 -0500
commitdef081f761fa12604a4618fab01fc192320e6360 (patch)
tree0ce8803f0fdf81c83deb753afc43e164288393af /dev-python/six
parentdev-php/pecl-imagick: Drop old (diff)
downloadgentoo-def081f761fa12604a4618fab01fc192320e6360.tar.gz
gentoo-def081f761fa12604a4618fab01fc192320e6360.tar.bz2
gentoo-def081f761fa12604a4618fab01fc192320e6360.zip
dev-python/six: Ensure PYTHON exists before calling python_get_sitedir
Package-Manager: portage-2.2.26_p10
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index ffbb168d3c24..810d8156f5fe 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -32,8 +32,8 @@ PATCHES=(
# pkg_setup to catch them all
pkg_pretend() {
six_dir_check() {
- local dir="${ROOT}"/$(python_get_sitedir)/six
type -p "${PYTHON}" > /dev/null || return 0
+ local dir="${ROOT}"/$(python_get_sitedir)/six
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}