summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-26 23:16:18 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-26 23:17:12 -0500
commitf520d401bb03a3186ec057ff2cd188077e656899 (patch)
treeb4f4d0bf75a27e95edc89af93390dfaeea92d7cd /dev-python/six
parentdev-ruby/facter: bup (diff)
downloadgentoo-f520d401bb03a3186ec057ff2cd188077e656899.tar.gz
gentoo-f520d401bb03a3186ec057ff2cd188077e656899.tar.bz2
gentoo-f520d401bb03a3186ec057ff2cd188077e656899.zip
dev-python/six: Force usage of distutils over setuptools
Avoids circular dependency. Bug: https://bugs.gentoo.org/572792 Package-Manager: portage-2.2.27_p49
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/files/1.10.0-no-setuptools.patch22
-rw-r--r--dev-python/six/six-1.10.0.ebuild6
-rw-r--r--dev-python/six/six-1.9.0-r1.ebuild6
3 files changed, 28 insertions, 6 deletions
diff --git a/dev-python/six/files/1.10.0-no-setuptools.patch b/dev-python/six/files/1.10.0-no-setuptools.patch
new file mode 100644
index 000000000000..d4309181902a
--- /dev/null
+++ b/dev-python/six/files/1.10.0-no-setuptools.patch
@@ -0,0 +1,22 @@
+Force distutils to avoid depending on setuptools
+
+distutils and setuptools have differing behavior in regard to egg-info
+directories versus files, so we need to ensure that no automagic behavior
+occurs here.
+
+We cannot hard-depend on setuptools due to a circular dependency.
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,6 @@
+ from __future__ import with_statement
+
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+ import six
+
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index cb6a767b3815..baf5f47fb3a2 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,13 +18,13 @@ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc
IUSE="doc test"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
PATCHES=(
+ "${FILESDIR}"/1.10.0-no-setuptools.patch
"${FILESDIR}"/1.9.0-mapping.patch
- )
+)
python_prepare_all() {
# https://bitbucket.org/gutworth/six/issues/139/
diff --git a/dev-python/six/six-1.9.0-r1.ebuild b/dev-python/six/six-1.9.0-r1.ebuild
index 6ab55582e454..7553b1d29d56 100644
--- a/dev-python/six/six-1.9.0-r1.ebuild
+++ b/dev-python/six/six-1.9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,14 +18,14 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
IUSE="doc test"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
PATCHES=(
+ "${FILESDIR}"/1.10.0-no-setuptools.patch
"${FILESDIR}"/${PV}-mapping.patch
"${FILESDIR}"/${P}-winreg.patch
- )
+)
python_compile_all() {
use doc && emake -C documentation html