summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjuippis <juippis@gmail.com>2018-04-11 18:12:06 +0300
committerMichał Górny <mgorny@gentoo.org>2018-06-02 20:40:40 +0200
commita469836189894501f27dabeb47db3679e06f93ca (patch)
tree9ae567811a0e7a59832c87b5e286f839cfa18889 /dev-python/texttable
parentdev-python/cjkwrap: new package (diff)
downloadgentoo-a469836189894501f27dabeb47db3679e06f93ca.tar.gz
gentoo-a469836189894501f27dabeb47db3679e06f93ca.tar.bz2
gentoo-a469836189894501f27dabeb47db3679e06f93ca.zip
dev-python/texttable: version bump to 1.2.1
Also, add myself as proxy-maintainer
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/metadata.xml13
-rw-r--r--dev-python/texttable/texttable-1.2.1.ebuild31
3 files changed, 42 insertions, 3 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index 552c7d199aa0..31dab6c294c1 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1,2 +1,3 @@
DIST texttable-0.8.3.tar.gz 8569 BLAKE2B 83b64ba6792b4243bed042f90e643272c045f39eefdd2ea33c9ed506f1cffbb8c683809edfa2061e7f5fc8815c6bbf67de0c8da7a90c6e77fb0d89b57fc41288 SHA512 d9a50f6fd9cd2a6d55afd5e686ac8ff2b2ebcf8c8041209ffae3e3864529c54a384840a65df2b87a942528005ca864d00bb01dfaeb33308843c01db7471931c8
DIST texttable-0.9.1.tar.gz 11074 BLAKE2B 465738a7b980f2a216d63b268044c1a1b8c0deb986fd398f0ba0ae30ab84020ac6f179b5314a2071592c38443f9cb86387b9ed573342533af9e825000472ebe5 SHA512 7ec37336ef4b253879d0232dcdb4500cad33ecce1067dd7ea26c221dc2c003ee56360bdbd1dd1e00133301c51c67fb2fe9b1703628804a65f2a6ab8a1e830e50
+DIST texttable-1.2.1.tar.gz 12075 BLAKE2B 050894d30c085599de6b61feaa7268f139e9d682e081f4b17eb96fc1344f35ab8ea8a740e4540511e5ac2232de0d6f2b98c740aa6e689b57b5634e2146fd2ab0 SHA512 7c6a49264b3b458ff3012e378ad5d6b1d466be6d6381e67915bfbd89ad3454c8d0bdc22684854a37901ee679bbd88a307f772ce70bd3bbf21070f5b4a1c95f94
diff --git a/dev-python/texttable/metadata.xml b/dev-python/texttable/metadata.xml
index a290a89e7b39..d96bfd447119 100644
--- a/dev-python/texttable/metadata.xml
+++ b/dev-python/texttable/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <upstream>
- <remote-id type="pypi">texttable</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>juippis@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">texttable</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/texttable/texttable-1.2.1.ebuild b/dev-python/texttable/texttable-1.2.1.ebuild
new file mode 100644
index 000000000000..33dddd685225
--- /dev/null
+++ b/dev-python/texttable/texttable-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v tests.py || die
+}