summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-11 08:48:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-11 10:01:38 +0200
commit665907fb5c7261e4ea74eea4db7c3249dc263860 (patch)
tree12ed8e89cdb9b0535129a48ba072886d3623d45f /dev-python
parentdev-python/botocore: Bump to 1.17.0 (diff)
downloadgentoo-665907fb5c7261e4ea74eea4db7c3249dc263860.tar.gz
gentoo-665907fb5c7261e4ea74eea4db7c3249dc263860.tar.bz2
gentoo-665907fb5c7261e4ea74eea4db7c3249dc263860.zip
dev-python/boto3: Bump to 1.14.0
No meaningful changes. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d5d86e439226..030276e147ba 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.10.2.tar.gz 272071 BLAKE2B 9c3b90ae751784946a84d0cf31ed0111526ed97b5be1fe5f256f725889f9819db632c6e6f217e3f01ebb0aa5594257a5bdaabd8dcc5f14ccb5bdd333b1c416c7 SHA512 37ea11f5ae9263aa5e97ce94f2834c987190ba2eac4a60bf9312bb643f1d204e48db7bef6ddc0d46ae124109ec6807589108b58f3024485de163fd8f83688b42
DIST boto3-1.12.48.tar.gz 292124 BLAKE2B 0baf8fb4cfa040ba05b296d15a523a5de32677684143145b12dd54182d4fedbffa5656d36ab854006c0cc6009a1bca351bb5ac2ea757cb70b446924bcae625a8 SHA512 3cf5533dd5d9aa51cf46ef81ba25bb7afbc73b1e745ea5ae47935b22da290c7d2101e377b3225f970168201dde0bf2ee967e24eed86548f9045eb72840afea6b
DIST boto3-1.13.26.tar.gz 296782 BLAKE2B 117bb18679fe3ae8c4feee1a5fb2d1df1923764bba3dce72040ccc802d10bb88263744a0491195f414761b6755353775a8a413a121a5a0fc42373a4e9b8aac1a SHA512 513ea4b39a5af4ae8e45f6b8b315a19d5184998fa881782bf2e6074aee36a709b51813fc9fe403bb8dbfb9b51ead50367af18f0918a1c88a37eab263ccddd11a
+DIST boto3-1.14.0.tar.gz 297008 BLAKE2B 7f5eaf4958395b47e936596b385b5a4daa20dbed6b777a407b6c2f70d3004d89fb963f479a1a3c8be22a3cbbfdb21f59a1f3c3ea4b967fce4799fc965899bcf1 SHA512 12ce4765f22e848aac0c29d1f95ed7b63964868f18c14073f93c74e442babf8708aa69cb6c17bd7c3aa5dacda6beb67bb4a4afe86fcd298308c70abfb77802d4
DIST boto3-1.9.122.tar.gz 258061 BLAKE2B 68903edd97e10693675e4c2fa77c2c54f2d3aab79307ee0a856f43aabe256f7782d027b0a23f433c593962c90f7364c26a87c27fe8770e67b5052e4ced73a9bc SHA512 31b8d8c2369b9076d825196d400c8a8b5579c38f87c7f41634eedbdaf6c2be01072018312e90e25d81b850c51f7c22a13fa565cd4e8b7672c238bad61e6a0810
diff --git a/dev-python/boto3/boto3-1.14.0.ebuild b/dev-python/boto3/boto3-1.14.0.ebuild
new file mode 100644
index 000000000000..062b762234a9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit tests/functional ||
+ die "test failed under ${EPYTHON}"
+}