summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:11:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:11:49 -0500
commit789ec36907f7cc688439d77ee5fe2938200ad914 (patch)
treedd207272232c47ee298a035ec6c05d008b69539e /dev-python
parentdev-python/python-saharaclient: 3.2.1 bump (diff)
downloadgentoo-789ec36907f7cc688439d77ee5fe2938200ad914.tar.gz
gentoo-789ec36907f7cc688439d77ee5fe2938200ad914.tar.bz2
gentoo-789ec36907f7cc688439d77ee5fe2938200ad914.zip
dev-python/python-zaqarclient: 2.0.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-zaqarclient/Manifest1
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-2.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/Manifest b/dev-python/python-zaqarclient/Manifest
index d5f6059c8cd8..4c85236f6589 100644
--- a/dev-python/python-zaqarclient/Manifest
+++ b/dev-python/python-zaqarclient/Manifest
@@ -1 +1,2 @@
DIST python-zaqarclient-1.13.1.tar.gz 88428 BLAKE2B 71870c7232d4f00b626421fc41e033925fe58f0699538d3e7f3deba2ac07e692d8e676eb763429efcc16ca0c39f8a15317106ca8f6ade583555a89495eba324c SHA512 4854e0a90e98d8172058316fbfcefc0a327a81ae870db28a51264b8e4b809383b652818506f734dd2b35648a544d0811046957c97a86f12d696021d54fbfa890
+DIST python-zaqarclient-2.0.1.tar.gz 86779 BLAKE2B 5c19de28ec9329542cc77281596043c746332ac568495a7845150d4449731fd31729c1c745c828f1ba4e4cfa2f64a189b53e982248d3d74e3618e05489e5f24a SHA512 31af3bf16ac821a3f204673c9359d5dcc56915d6f108c0127cad6541ea6760be5b543c839fe053593905b5d876a6910a9038661d818e50af5f986eac442accd4
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-2.0.1.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-2.0.1.ebuild
new file mode 100644
index 000000000000..ee27203447bd
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+"