summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 11:50:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 12:02:06 +0200
commit8436dbe48688c60b73fc3ff7e996dbce48db36ce (patch)
tree5db9f05562995ee9af787cb80ad47e1b57ae5007 /dev-python
parentdev-python/oslo-context: Enable tests (diff)
downloadgentoo-8436dbe48688c60b73fc3ff7e996dbce48db36ce.tar.gz
gentoo-8436dbe48688c60b73fc3ff7e996dbce48db36ce.tar.bz2
gentoo-8436dbe48688c60b73fc3ff7e996dbce48db36ce.zip
dev-python/oslo-i18n: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
index 940d62e22546..6a6a36d92ac0 100644
--- a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
+++ b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_8 )
inherit distutils-r1 vcs-snapshot
MY_PN=${PN/-/.}
@@ -19,8 +18,14 @@ KEYWORDS="amd64 ~arm arm64 x86"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"
+BDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest