summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-06 17:31:43 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-10 02:05:04 +0000
commit9703bdbc7b449cba83ab817790868ed98129721d (patch)
treeb9c1664fd86570a2a4d2da72e5893299caa1115f /dev-python
parentdev-libs/librdkafka: Bump to v0.9.2 (diff)
downloadgentoo-9703bdbc7b449cba83ab817790868ed98129721d.tar.gz
gentoo-9703bdbc7b449cba83ab817790868ed98129721d.tar.bz2
gentoo-9703bdbc7b449cba83ab817790868ed98129721d.zip
dev-python/telarchive: initial import
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/telarchive/Manifest1
-rw-r--r--dev-python/telarchive/metadata.xml18
-rw-r--r--dev-python/telarchive/telarchive-1.8.3.ebuild23
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/telarchive/Manifest b/dev-python/telarchive/Manifest
new file mode 100644
index 000000000000..053cf67b50bd
--- /dev/null
+++ b/dev-python/telarchive/Manifest
@@ -0,0 +1 @@
+DIST telarchive-1.8.3.tar.gz 79377 SHA256 97d1668027bee5036b7596608dd8f86d078283763f2ed0abf3850fa0276faf06 SHA512 628937f8556d7197317aaa08b0ed757d92770a0929e77ea30245c1e52a3bf04e425d86c16e4711359634d0156f1d7128780abbead163ed119262fae22e9f35ae WHIRLPOOL 6d329d0b0984e7ad0b1c5ba2c8a4d565592889000cfda77f52c9ddcd2195a5c283a24a18382c6766c4873087d9554127a12ddbd26d3af12a12a0654cdbd8a7a4
diff --git a/dev-python/telarchive/metadata.xml b/dev-python/telarchive/metadata.xml
new file mode 100644
index 000000000000..498822a1f085
--- /dev/null
+++ b/dev-python/telarchive/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ telarchive is a Python command-line program for searching multiple
+ public telescope archives. It takes the name of an astronomical
+ object -- or a set of coordinates -- and checks the telescope
+ archives to see if they have observations within a user-specified
+ box centered on the object/coordinates.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">telarchive</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/telarchive/telarchive-1.8.3.ebuild b/dev-python/telarchive/telarchive-1.8.3.ebuild
new file mode 100644
index 000000000000..5d389f93b32b
--- /dev/null
+++ b/dev-python/telarchive/telarchive-1.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Script for automated searches of astronomical telescope archives"
+HOMEPAGE="http://www.mpe.mpg.de/~erwin/code/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"