summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 11:52:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 12:24:41 +0200
commit3b11b1c8844f17fd7f46fa10256b355317dc3a46 (patch)
tree3485743d2ab92535f66734aae79382c94e83149f /dev-qt/qtlocation/qtlocation-5.12.4.ebuild
parentmedia-libs/avidemux-plugins: Drop 2.6.20 (diff)
downloadgentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.gz
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.bz2
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.zip
dev-qt: Add Qt 5.12.4
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-5.12.4.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.12.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.12.4.ebuild b/dev-qt/qtlocation/qtlocation-5.12.4.ebuild
new file mode 100644
index 000000000000..e1e230b43e26
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.12.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}