summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:59:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:59:48 +0200
commit99c9d92b69ec81c6de4f698bce511e0b4a609122 (patch)
treece76a70deec5b92b98e19cd0aee4e39a7e3d6f46 /dev-ros/image_proc/image_proc-9999.ebuild
parentdev-ros/depth_image_proc: Initial import. Ebuild by me. (diff)
downloadgentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.tar.gz
gentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.tar.bz2
gentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.zip
dev-ros/image_proc: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/image_proc/image_proc-9999.ebuild')
-rw-r--r--dev-ros/image_proc/image_proc-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_proc/image_proc-9999.ebuild b/dev-ros/image_proc/image_proc-9999.ebuild
new file mode 100644
index 000000000000..fc4695ace629
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"