summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:17:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:17:59 +0200
commit706008c5592fd9a3a63362de2c7de8be8f7bd1d0 (patch)
treeb042b10c3260bdd27091561e28a56556b190031a /dev-ros/moveit_msgs/moveit_msgs-9999.ebuild
parentdev-ros/octomap_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.tar.gz
gentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.tar.bz2
gentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.zip
dev-ros/moveit_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/moveit_msgs/moveit_msgs-9999.ebuild')
-rw-r--r--dev-ros/moveit_msgs/moveit_msgs-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild b/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild
new file mode 100644
index 000000000000..1a0bf19f0eb5
--- /dev/null
+++ b/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/moveit_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/sensor_msgs
+ dev-ros/geometry_msgs
+ dev-ros/trajectory_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+ dev-ros/octomap_msgs
+ dev-ros/object_recognition_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages, services and actions used by MoveIt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"