summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 16:48:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:32:46 +0200
commit4a1baa179de8dc50bf9624a197c11aee5c0fa2ad (patch)
tree5d83ad8ae4401c6cbc7d0d8f3e6af1f5e4c786fa /dev-ros/rosauth
parentdev-ros/roscreate: fix tests (diff)
downloadgentoo-4a1baa179de8dc50bf9624a197c11aee5c0fa2ad.tar.gz
gentoo-4a1baa179de8dc50bf9624a197c11aee5c0fa2ad.tar.bz2
gentoo-4a1baa179de8dc50bf9624a197c11aee5c0fa2ad.zip
dev-ros/rosauth: fix tests
Closes: https://bugs.gentoo.org/624926 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosauth')
-rw-r--r--dev-ros/rosauth/rosauth-1.0.1.ebuild5
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/rosauth/rosauth-1.0.1.ebuild b/dev-ros/rosauth/rosauth-1.0.1.ebuild
index 2bccb46f88d1..10f5ea08a15f 100644
--- a/dev-ros/rosauth/rosauth-1.0.1.ebuild
+++ b/dev-ros/rosauth/rosauth-1.0.1.ebuild
@@ -22,3 +22,8 @@ DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-cpp/gtest
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
index 2bccb46f88d1..10f5ea08a15f 100644
--- a/dev-ros/rosauth/rosauth-9999.ebuild
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -22,3 +22,8 @@ DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-cpp/gtest
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}