summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:32:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit2873f205f28d7d976b45127822a0ac79ef73237d (patch)
tree103bd1e0e52b4cd72566d3b4fe948c0f62ee9a51 /dev-ros/rosmsg/rosmsg-1.11.15.ebuild
parentdev-ros/rosmaster: Bump to 1.11.15. (diff)
downloadgentoo-2873f205f28d7d976b45127822a0ac79ef73237d.tar.gz
gentoo-2873f205f28d7d976b45127822a0ac79ef73237d.tar.bz2
gentoo-2873f205f28d7d976b45127822a0ac79ef73237d.zip
dev-ros/rosmsg: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.11.15.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.11.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.11.15.ebuild b/dev-ros/rosmsg/rosmsg-1.11.15.ebuild
new file mode 100644
index 000000000000..d7da61f40053
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.11.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"