summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.11.15.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.11.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.11.15.ebuild b/dev-ros/rosmsg/rosmsg-1.11.15.ebuild
new file mode 100644
index 000000000000..d7da61f40053
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.11.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"