summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:21:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:28 +0200
commit50d77c7e688ec4135a32f1945c1e881d456e0c32 (patch)
tree877fee479c659a23227501d153900cd4d42b86ed /dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild
parentdev-ros/rqt_nav_view: remove old (diff)
downloadgentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.tar.gz
gentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.tar.bz2
gentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.zip
dev-ros/rqt_nav_view: bump to 0.5.7 and switch to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild')
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild
new file mode 100644
index 000000000000..3d2eb643f259
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_nav_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"