summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-28 15:04:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-28 15:04:30 +0200
commit14f28e795137ce7e399449767cbe1b91d2526f64 (patch)
treedfe3b0eac11ae200db5bf3587c9e4b76a4f534a7 /dev-ros/sound_play/sound_play-9999.ebuild
parentdev-ros/audio_capture: Initial import. Ebuild by me. (diff)
downloadgentoo-14f28e795137ce7e399449767cbe1b91d2526f64.tar.gz
gentoo-14f28e795137ce7e399449767cbe1b91d2526f64.tar.bz2
gentoo-14f28e795137ce7e399449767cbe1b91d2526f64.zip
dev-ros/sound_play: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/sound_play/sound_play-9999.ebuild')
-rw-r--r--dev-ros/sound_play/sound_play-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/sound_play/sound_play-9999.ebuild b/dev-ros/sound_play/sound_play-9999.ebuild
new file mode 100644
index 000000000000..c4b4cb101276
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:0.10
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"