summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/magic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/magic')
-rw-r--r--dev-ruby/magic/Manifest1
-rw-r--r--dev-ruby/magic/magic-0.2.9.ebuild32
-rw-r--r--dev-ruby/magic/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/magic/Manifest b/dev-ruby/magic/Manifest
new file mode 100644
index 000000000000..158d303b37eb
--- /dev/null
+++ b/dev-ruby/magic/Manifest
@@ -0,0 +1 @@
+DIST magic-0.2.9.tar.gz 11642 SHA256 dabc0278a8a22b2cc19195cbeca6de014be770de2864c0e800be266623feaeeb SHA512 5bc6d6e1b2646b12af7dad15273dc125db68be2d6e6c109484339c8f651349827a90ea81d8feb0441c5811567d85130cda35167e2dbb426842f952fc2ff8ea15 WHIRLPOOL 1ee21f1810df75470c678b6dbf4e39680e72394a7ec20cc687d03a16d6d77b86b87ff42b858eccefc42aa3e1a475bcd482c66dffcc45b46ac0bbba71c1d186ec
diff --git a/dev-ruby/magic/magic-0.2.9.ebuild b/dev-ruby/magic/magic-0.2.9.ebuild
new file mode 100644
index 000000000000..e12100feba4b
--- /dev/null
+++ b/dev-ruby/magic/magic-0.2.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/qoobaa/magic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Ruby FFI bindings to libmagic"
+HOMEPAGE="https://github.com/qoobaa/magic"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND+="sys-apps/file"
+DEPEND+="test? ( sys-apps/file )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+ruby_add_rdepend "virtual/ruby-ffi"
+
+each_ruby_test() {
+ ${RUBY} -Ilib -Itest test/test_magic.rb || die
+}
diff --git a/dev-ruby/magic/metadata.xml b/dev-ruby/magic/metadata.xml
new file mode 100644
index 000000000000..44ecb3d5293f
--- /dev/null
+++ b/dev-ruby/magic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">qoobaa/magic</remote-id>
+ </upstream>
+</pkgmetadata>