summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/magic')
-rw-r--r--dev-ruby/magic/Manifest1
-rw-r--r--dev-ruby/magic/magic-0.2.9.ebuild32
-rw-r--r--dev-ruby/magic/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/magic/Manifest b/dev-ruby/magic/Manifest
new file mode 100644
index 000000000000..158d303b37eb
--- /dev/null
+++ b/dev-ruby/magic/Manifest
@@ -0,0 +1 @@
+DIST magic-0.2.9.tar.gz 11642 SHA256 dabc0278a8a22b2cc19195cbeca6de014be770de2864c0e800be266623feaeeb SHA512 5bc6d6e1b2646b12af7dad15273dc125db68be2d6e6c109484339c8f651349827a90ea81d8feb0441c5811567d85130cda35167e2dbb426842f952fc2ff8ea15 WHIRLPOOL 1ee21f1810df75470c678b6dbf4e39680e72394a7ec20cc687d03a16d6d77b86b87ff42b858eccefc42aa3e1a475bcd482c66dffcc45b46ac0bbba71c1d186ec
diff --git a/dev-ruby/magic/magic-0.2.9.ebuild b/dev-ruby/magic/magic-0.2.9.ebuild
new file mode 100644
index 000000000000..e12100feba4b
--- /dev/null
+++ b/dev-ruby/magic/magic-0.2.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/qoobaa/magic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Ruby FFI bindings to libmagic"
+HOMEPAGE="https://github.com/qoobaa/magic"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND+="sys-apps/file"
+DEPEND+="test? ( sys-apps/file )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+ruby_add_rdepend "virtual/ruby-ffi"
+
+each_ruby_test() {
+ ${RUBY} -Ilib -Itest test/test_magic.rb || die
+}
diff --git a/dev-ruby/magic/metadata.xml b/dev-ruby/magic/metadata.xml
new file mode 100644
index 000000000000..44ecb3d5293f
--- /dev/null
+++ b/dev-ruby/magic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">qoobaa/magic</remote-id>
+ </upstream>
+</pkgmetadata>