summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/multi_xml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/multi_xml')
-rw-r--r--dev-ruby/multi_xml/Manifest2
-rw-r--r--dev-ruby/multi_xml/metadata.xml5
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild33
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.4-r2.ebuild34
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.5.ebuild35
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-ruby/multi_xml/Manifest b/dev-ruby/multi_xml/Manifest
new file mode 100644
index 000000000000..067a1ebc2ea6
--- /dev/null
+++ b/dev-ruby/multi_xml/Manifest
@@ -0,0 +1,2 @@
+DIST multi_xml-0.5.4.gem 20992 SHA256 6365ba9aced7eb993b6237a5a6d8c854be5cd84ad2ea1aad4de63ee0bf3bfd53 SHA512 d78ae3c401741c4d396bed6074efd24e8712cd70d9b9ef7008abb3ff662edc2292be42dfbd101be384aaf2ce207271004eb7b7cadccba746b9afe385a9fbdb7a WHIRLPOOL 5aaefe9e3db22e0fa4b0922d35acc19370bb9866701d1761c6ed45142548d6ad67585a9323ef382019a0be239b11fb474c0461af2153cdfcc6c678a8f704b0e2
+DIST multi_xml-0.5.5.gem 20992 SHA256 08936dc294586ee1d178217cce577febe26315d7880e01e4f8e97cf2753b1945 SHA512 692f55908ec5e9ee27bec858325ff9a0b15037a6563d5a21bd742ec3c959f3dbc04f1a232782f20827c9af49f3dd14fd725a0c19dbacb3708067c19dedf427ba WHIRLPOOL e21f6239983c9f88d32f5f90266e18d1d533bc4c5735bf0d8ea5f1fb32ec2b2f2814305bf86809ae6f2098560e5ed8fa774a879ee9c337b6663933b1100f924d
diff --git a/dev-ruby/multi_xml/metadata.xml b/dev-ruby/multi_xml/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/multi_xml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..71e7401a21ef
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.4-r2.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.4-r2.ebuild
new file mode 100644
index 000000000000..f5fe3d7567ad
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.5.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.5.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.5.ebuild
new file mode 100644
index 000000000000..6154b69eea8c
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/ox )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}