summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cunit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cunit')
-rw-r--r--dev-util/cunit/Manifest2
-rw-r--r--dev-util/cunit/cunit-2.1-r1.ebuild38
-rw-r--r--dev-util/cunit/cunit-2.1_p2-r1.ebuild55
-rw-r--r--dev-util/cunit/cunit-2.1_p2.ebuild49
-rw-r--r--dev-util/cunit/metadata.xml8
5 files changed, 152 insertions, 0 deletions
diff --git a/dev-util/cunit/Manifest b/dev-util/cunit/Manifest
new file mode 100644
index 000000000000..f1fbfa585dd1
--- /dev/null
+++ b/dev-util/cunit/Manifest
@@ -0,0 +1,2 @@
+DIST CUnit-2.1-0-src.tar.gz 628767 SHA256 b5fc0ab0f03e8d287a3f65935c7e36fabfdcd9f926ee6f50ac621ea6ab6fa8c6 SHA512 564c297293e3578384c11daef70bc45619188ff823107a2bbb6e56cfa702941b1c316cd9a4cb1116ecc5aefababd153febc39907296392b59e669d3251f85fbf WHIRLPOOL be977c03f15a571e35fb557239a70ef281f5dd9580faf4077b51ba4f80d96b824d650d4a3eb53ec34b9ffb3e08cc06ab4bc6a830f4f60ac8818f95a8556328b8
+DIST CUnit-2.1-2-src.tar.bz2 349037 SHA256 1f705f30b36fe1dadb5494989d1d663241603f456b468c81f606a1bdbc168bea SHA512 c0af37b9f3a00fd7bb971f33e94373699d0380c28fad12f6db860739990a9ffffe0bb0a71c0e3531529b9952128c11248b8f365875d0315c16637a0b7e91642d WHIRLPOOL a5617aa10baf617e7165c04c66e4fffb25d2d8d396d8aff8ed5f67183154d79514d2c426c88bc02d02440f4c53bbe2b6025bbd0165fa3a6008e2b19e0317498b
diff --git a/dev-util/cunit/cunit-2.1-r1.ebuild b/dev-util/cunit/cunit-2.1-r1.ebuild
new file mode 100644
index 000000000000..64321014533a
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils autotools
+
+MY_PN='CUnit'
+MY_PV="${PV}-0"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.gz"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "/^docdir/d" -i doc/Makefile.am
+ sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \
+ -i doc/headers/Makefile.am
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README ChangeLog
+}
diff --git a/dev-util/cunit/cunit-2.1_p2-r1.ebuild b/dev-util/cunit/cunit-2.1_p2-r1.ebuild
new file mode 100644
index 000000000000..19aeace2416b
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1_p2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib-minimal toolchain-funcs
+
+MY_PN='CUnit'
+MY_PV="${PV/_p*}-2"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.bz2"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ncurses static-libs"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+src_prepare() {
+ sed -e "/^docdir/d" -i doc/Makefile.am || die
+ sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \
+ -i doc/headers/Makefile.am || die
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+
+ append-cppflags -D_BSD_SOURCE
+
+ # unable to find headers otherwise
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local LIBS=${LIBS}
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ --disable-debug \
+ $(use_enable ncurses curses)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-util/cunit/cunit-2.1_p2.ebuild b/dev-util/cunit/cunit-2.1_p2.ebuild
new file mode 100644
index 000000000000..854eccb3f7a8
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1_p2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+MY_PN='CUnit'
+MY_PV="${PV/_p*}-2"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.bz2"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ncurses static-libs"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+src_prepare() {
+ sed -e "/^docdir/d" -i doc/Makefile.am || die
+ sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \
+ -i doc/headers/Makefile.am || die
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+ append-cppflags -D_BSD_SOURCE
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ --disable-debug \
+ $(use_enable ncurses curses)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-util/cunit/metadata.xml b/dev-util/cunit/metadata.xml
new file mode 100644
index 000000000000..875d63833a63
--- /dev/null
+++ b/dev-util/cunit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lang-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">cunit</remote-id>
+ </upstream>
+</pkgmetadata>