summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 10:48:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 10:49:00 +0200
commit7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb (patch)
treedd0dd70546756e0822cadfdea2d2102ee41e5b53 /dev-vcs
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.tar.gz
gentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.tar.bz2
gentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.zip
dev-vcs/git: Replace "libsecret" by "gnome-keyring" USE flag (bug #619484)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.12.3.ebuild8
-rw-r--r--dev-vcs/git/git-2.13.0.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild8
-rw-r--r--dev-vcs/git/git-9999.ebuild8
-rw-r--r--dev-vcs/git/metadata.xml1
7 files changed, 24 insertions, 25 deletions
diff --git a/dev-vcs/git/git-2.12.3.ebuild b/dev-vcs/git/git-2.12.3.ebuild
index e1c531411ace..f58a551ff7bc 100644
--- a/dev-vcs/git/git-2.12.3.ebuild
+++ b/dev-vcs/git/git-2.12.3.ebuild
@@ -43,13 +43,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -359,7 +359,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -454,7 +454,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/git-2.13.0.ebuild b/dev-vcs/git/git-2.13.0.ebuild
index 236e9870a18c..8db4d054f323 100644
--- a/dev-vcs/git/git-2.13.0.ebuild
+++ b/dev-vcs/git/git-2.13.0.ebuild
@@ -43,13 +43,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -359,7 +359,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -454,7 +454,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 581efda16671..73c3a63eff54 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index f725b2c09472..269086404b39 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 29ed4c46363b..1d5145652541 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index c9be0f22ff20..1d2603cd7495 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi
diff --git a/dev-vcs/git/metadata.xml b/dev-vcs/git/metadata.xml
index f7c661156294..4a8fe9f2743b 100644
--- a/dev-vcs/git/metadata.xml
+++ b/dev-vcs/git/metadata.xml
@@ -29,7 +29,6 @@
<flag name="curl">Support fetching and pushing (requires webdav too) over http:// and https:// protocols</flag>
<flag name="gpg">Pull in gnupg for signing -- without gnupg, attempts at signing will fail at runtime!</flag>
<flag name="highlight">GitWeb support for app-text/highlight</flag>
- <flag name="libsecret">Enable libsecret support to store login credentials</flag>
<flag name="mediawiki">Support pulling and pushing from MediaWiki</flag>
<flag name="mediawiki-experimental">Add experimental patches for improved MediaWiki support</flag>
<flag name="ppcsha1">Make use of a bundled routine that is optimized for the PPC arch</flag>