summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/trine-bin/trine-bin-1.08.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/trine-bin/trine-bin-1.08.ebuild')
-rw-r--r--games-action/trine-bin/trine-bin-1.08.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-action/trine-bin/trine-bin-1.08.ebuild b/games-action/trine-bin/trine-bin-1.08.ebuild
new file mode 100644
index 000000000000..a4d3d63715f1
--- /dev/null
+++ b/games-action/trine-bin/trine-bin-1.08.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# these are ELFs that include a ZIP (504b0304) appended to it
+# dd if=Trine.64.run of=Trine.64.zip ibs=$((0x342a8)) skip=1
+# dd if=Trine.32.run of=Trine.32.zip ibs=$((0x31c24)) skip=1
+# but `unzip` will skip the ELF at the start. both ELFs contain
+# the same zip appended, so only need to hash one of them.
+
+EAPI=5
+inherit unpacker games eutils
+
+DESCRIPTION="a physics-based action game where diff characters allow diff solutions to challenges"
+HOMEPAGE="http://trine-thegame.com/"
+SRC_URI="Trine.64.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0
+ dev-libs/libx86
+ gnome-base/libglade"
+
+S=${WORKDIR}
+
+d=${GAMES_PREFIX_OPT}/${PN}
+QA_PRESTRIPPED="${d#/}/trine-launcher ${d#/}/trine-bin ${d#/}/lib*/lib*.so*"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unpack_zip ${A}
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+}
+
+src_install() {
+ local b bb
+ local sfx=$(use x86 && echo 32 || echo 64)
+
+ doicon Trine.xpm
+ for b in bin launcher ; do
+ bb="trine-${b}"
+ exeinto ${d}
+ newexe ${bb}${sfx} ${bb}
+ games_make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Trine ${b}" Trine
+ done
+
+ exeinto ${d}/lib${sfx}
+ doexe lib${sfx}/*
+
+ insinto ${d}
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png
+
+ dodoc Trine_Manual_linux.pdf Trine_updates.txt
+
+ prepgamesdirs
+}