summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild')
-rw-r--r--games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild b/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..1f8d1a361325
--- /dev/null
+++ b/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Squash the monsters with your levitation worker gnome"
+HOMEPAGE="http://people.iola.dk/olau/monster-masher/"
+SRC_URI="http://people.iola.dk/olau/monster-masher/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libSM
+ >=dev-cpp/gtkmm-2.6:2.4
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4:2.4
+ >=dev-cpp/libgnomecanvasmm-2.6:2.6
+ gnome-base/libgnome
+ media-libs/libcanberra
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # Port to libcanberra, bug #348605
+ epatch "${FILESDIR}"/${P}-libcanberra.patch
+
+ # Fix .desktop file
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # build with newer glib - bug #424313
+ sed -i -e 's:glib/gtypes:glib:' src/pixbuf-drawing.hpp || die
+
+ eautoreconf
+ gnome2_src_prepare
+}