summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild')
-rw-r--r--games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild b/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..1f8d1a361325
--- /dev/null
+++ b/games-arcade/monster-masher/monster-masher-1.8.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Squash the monsters with your levitation worker gnome"
+HOMEPAGE="http://people.iola.dk/olau/monster-masher/"
+SRC_URI="http://people.iola.dk/olau/monster-masher/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libSM
+ >=dev-cpp/gtkmm-2.6:2.4
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4:2.4
+ >=dev-cpp/libgnomecanvasmm-2.6:2.6
+ gnome-base/libgnome
+ media-libs/libcanberra
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # Port to libcanberra, bug #348605
+ epatch "${FILESDIR}"/${P}-libcanberra.patch
+
+ # Fix .desktop file
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # build with newer glib - bug #424313
+ sed -i -e 's:glib/gtypes:glib:' src/pixbuf-drawing.hpp || die
+
+ eautoreconf
+ gnome2_src_prepare
+}