summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 00:25:13 +0000
committerSam James <sam@gentoo.org>2022-03-20 00:25:13 +0000
commit9c2a341fbbc3fa0f15b48c0c49b4fed99e10ad71 (patch)
treed027aea37ecf3561596d0e0b4ff77e2460f83d86 /games-board
parentsys-devel/slibtool: [QA] fix tc-get* quoting (diff)
downloadgentoo-9c2a341fbbc3fa0f15b48c0c49b4fed99e10ad71.tar.gz
gentoo-9c2a341fbbc3fa0f15b48c0c49b4fed99e10ad71.tar.bz2
gentoo-9c2a341fbbc3fa0f15b48c0c49b4fed99e10ad71.zip
games-board/stockfish: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/stockfish/stockfish-10.ebuild6
-rw-r--r--games-board/stockfish/stockfish-13.ebuild6
-rw-r--r--games-board/stockfish/stockfish-14.1.ebuild6
-rw-r--r--games-board/stockfish/stockfish-14.ebuild6
4 files changed, 12 insertions, 12 deletions
diff --git a/games-board/stockfish/stockfish-10.ebuild b/games-board/stockfish/stockfish-10.ebuild
index 5974776f35e1..f8c2aa054feb 100644
--- a/games-board/stockfish/stockfish-10.ebuild
+++ b/games-board/stockfish/stockfish-10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,8 +57,8 @@ src_compile() {
# COMPILER to support Travis CI and we abuse it to make sure that we
# build with our compiler of choice.
emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
debug=$(usex debug "yes" "no") \
optimize=$(usex optimize "yes" "no")
}
diff --git a/games-board/stockfish/stockfish-13.ebuild b/games-board/stockfish/stockfish-13.ebuild
index 69d38bbeee91..7e9dda906792 100644
--- a/games-board/stockfish/stockfish-13.ebuild
+++ b/games-board/stockfish/stockfish-13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,8 +62,8 @@ src_compile() {
# COMPILER to support Travis CI and we abuse it to make sure that we
# build with our compiler of choice.
emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
debug=$(usex debug "yes" "no") \
optimize=$(usex optimize "yes" "no")
}
diff --git a/games-board/stockfish/stockfish-14.1.ebuild b/games-board/stockfish/stockfish-14.1.ebuild
index 95f30e5ff4b6..2ccc74178557 100644
--- a/games-board/stockfish/stockfish-14.1.ebuild
+++ b/games-board/stockfish/stockfish-14.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,8 +62,8 @@ src_compile() {
# COMPILER to support Travis CI and we abuse it to make sure that we
# build with our compiler of choice.
emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
debug=$(usex debug "yes" "no") \
optimize=$(usex optimize "yes" "no")
}
diff --git a/games-board/stockfish/stockfish-14.ebuild b/games-board/stockfish/stockfish-14.ebuild
index 4fb8113d9839..dd2f85f84bc6 100644
--- a/games-board/stockfish/stockfish-14.ebuild
+++ b/games-board/stockfish/stockfish-14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,8 +62,8 @@ src_compile() {
# COMPILER to support Travis CI and we abuse it to make sure that we
# build with our compiler of choice.
emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
debug=$(usex debug "yes" "no") \
optimize=$(usex optimize "yes" "no")
}