summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 17:24:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-30 23:09:34 +0200
commite1fd6e3ae5cc11bb5c4cd7354b185200eed8f3f9 (patch)
tree7e47061552300f57f8d4bbf9faac7474cd63b390 /games-puzzle
parentgames-puzzle/sgt-puzzles: EAPI-7 bump, drop IUSE=gtk3, fix menu entry (diff)
downloadgentoo-e1fd6e3ae5cc11bb5c4cd7354b185200eed8f3f9.tar.gz
gentoo-e1fd6e3ae5cc11bb5c4cd7354b185200eed8f3f9.tar.bz2
gentoo-e1fd6e3ae5cc11bb5c4cd7354b185200eed8f3f9.zip
games-puzzle/sgt-puzzles: Drop defunct 99999999 version
Upstream switched to cmake, patch broken, needs complete rework. Closes: https://bugs.gentoo.org/769167 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/Manifest1
-rw-r--r--games-puzzle/sgt-puzzles/metadata.xml3
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild115
3 files changed, 0 insertions, 119 deletions
diff --git a/games-puzzle/sgt-puzzles/Manifest b/games-puzzle/sgt-puzzles/Manifest
index f6eeba83f95f..94246fc13597 100644
--- a/games-puzzle/sgt-puzzles/Manifest
+++ b/games-puzzle/sgt-puzzles/Manifest
@@ -1,2 +1 @@
DIST puzzles-20190415.e2135d5.tar.gz 3286744 BLAKE2B 6b19cde3f95b5375bde74923a5f8e3deb9abb7d4d737ad5f2d18aa7895b973a9ca1ed4a495cf80da8390ed7fb63f1eb973c8053d52145e5752c56e38d3ac19d7 SHA512 5f38c96cff4e745a1c1615762c0e5f3f3dd056ff7dbf0f80a5953e658ae1460503c6394fe29301f5682485d6a6121869853a270dc60327821a3059ca6d971fa1
-DIST sgt-puzzles-icons-20160315.tar.xz 715536 BLAKE2B c50b3a6a0d0f8a052215dd9fba7c3eca5822bc7f866a825ad5e92391bb1867d141793877bc7c4545cc6da674bf273752612f7d3578a6a05b22cc2552ea798ce6 SHA512 2fe2c02984eb8c36ac6fb4195be7895b336b84f40ce8baeb23dc8a32aca9937ccf1d33050b4da3cfba3c87e124ecbdd940ee4e990b37eabe8e2af897c2e23b57
diff --git a/games-puzzle/sgt-puzzles/metadata.xml b/games-puzzle/sgt-puzzles/metadata.xml
index 697024d76f6e..fa736384b59a 100644
--- a/games-puzzle/sgt-puzzles/metadata.xml
+++ b/games-puzzle/sgt-puzzles/metadata.xml
@@ -9,7 +9,4 @@
<email>np-hardass@gentoo.org</email>
<name>Adam Feldman</name>
</maintainer>
- <use>
- <flag name="gtk3">Use x11-libs/gtk+:3 instead of x11-libs/gtk+:2</flag>
- </use>
</pkgmetadata>
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
deleted file mode 100644
index 2988d396d974..000000000000
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils gnome2-utils toolchain-funcs autotools
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.tartarus.org/simon/puzzles.git"
- GENTOO_ICONS="20160315"
- SRC_URI="https://dev.gentoo.org/~np-hardass/distfiles/${PN}/${PN}-icons-${GENTOO_ICONS}.tar.xz"
-else
- MAGIC=e2135d5
- SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.${MAGIC}.tar.gz"
- S=${WORKDIR}/puzzles-${PV}.${MAGIC}
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
-HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+doc gtk3"
-
-COMMON_DEPEND="
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? ( x11-libs/gtk+:3 )"
-
-RDEPEND="${COMMON_DEPEND}
- x11-misc/xdg-utils" # Used by builtin help patch
-
-DEPEND="${COMMON_DEPEND}
- dev-lang/perl
- virtual/pkgconfig
- doc? ( >=app-doc/halibut-1.2 )"
-
-PATCHES=( "${FILESDIR}/${PN}-20161207-builtin-help.patch" )
-
-src_unpack() {
- default
- if [[ ${PV} == "99999999" ]]; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-Werror||g' \
- configure.ac || die
- sed -i \
- -e 's/-O2 -Wall .* -g/-Wall/' \
- -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
- mkfiles.pl || die
- ./mkfiles.pl || die
- eautoreconf
-
- # Import icons from latest Gentoo tarball for live
- if [[ ${PV} == "99999999" ]]; then
- cp -R ../${PN}-icons/icons . || die
- fi
-}
-
-src_configure() {
- econf \
- --program-prefix="${PN}_" \
- --with-gtk=$(usex gtk3 3 2)
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
- if use doc ; then
- halibut --text --html --info --pdf --ps puzzles.but || die
- fi
-}
-
-src_install() {
- default
-
- local file name
- for file in *.R ; do
- [[ ${file} == "nullgame.R" ]] && continue
- name=$(awk -F: '/exe:/ { print $3 }' "${file}")
- file=${file%.R}
- newicon -s 48 icons/${file}-48d24.png ${PN}_${file}.png
- make_desktop_entry "${PN}_${file}" "${name}" "${PN}_${file}" "Game;LogicGame;X-${PN};"
- done
-
- if use doc ; then
- DOCS=( puzzles.{pdf,ps,txt} )
- HTML_DOCS=( *.html )
- einstalldocs
- doinfo puzzles.info{,-1,-2,-3}
- fi
-
- insinto /etc/xdg/menus/applications-merged
- doins "${FILESDIR}/${PN}.menu"
- insinto /usr/share/desktop-directories
- doins "${FILESDIR}/${PN}.directory"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}