summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/planets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/planets')
-rw-r--r--games-simulation/planets/Manifest1
-rw-r--r--games-simulation/planets/metadata.xml5
-rw-r--r--games-simulation/planets/planets-0.1.13.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-simulation/planets/Manifest b/games-simulation/planets/Manifest
new file mode 100644
index 000000000000..2bbf4fef6cc3
--- /dev/null
+++ b/games-simulation/planets/Manifest
@@ -0,0 +1 @@
+DIST planets-0.1.13.tgz 49732 SHA256 cd4be19dc1e16cc3d5bb20fdfa2af025b50cd21dbce5d1e8b3041c4e786c3624 SHA512 fdfc2cde52baaac71683fbf31b6fe09f6bec81650842eb6b88dbc34d643142f73a89a935db028ab000d3fa33e1646b28558e398bb0eddba273f94e429e61a67d WHIRLPOOL 3980b333761185525d4f91caee6f850d086954c5f119b66827f3a1b4a91e85d35a302fad941139732d1e813d539172652beda5fe7776f78925a6d8fc33c4cf0b
diff --git a/games-simulation/planets/metadata.xml b/games-simulation/planets/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/planets/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/planets/planets-0.1.13.ebuild b/games-simulation/planets/planets-0.1.13.ebuild
new file mode 100644
index 000000000000..19f0eb25337b
--- /dev/null
+++ b/games-simulation/planets/planets-0.1.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="a simple interactive planetary system simulator"
+HOMEPAGE="http://planets.homedns.org/"
+SRC_URI="http://planets.homedns.org/dist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-lang/tk:0="
+DEPEND="${RDEPEND}
+ dev-lang/ocaml[tk]"
+
+src_install() {
+ dogamesbin planets
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+ dohtml getting_started.html
+ dodoc CHANGES CREDITS KEYBINDINGS.txt README TODO
+ prepgamesdirs
+}