summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/planets')
-rw-r--r--games-simulation/planets/Manifest1
-rw-r--r--games-simulation/planets/metadata.xml5
-rw-r--r--games-simulation/planets/planets-0.1.13.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-simulation/planets/Manifest b/games-simulation/planets/Manifest
new file mode 100644
index 000000000000..2bbf4fef6cc3
--- /dev/null
+++ b/games-simulation/planets/Manifest
@@ -0,0 +1 @@
+DIST planets-0.1.13.tgz 49732 SHA256 cd4be19dc1e16cc3d5bb20fdfa2af025b50cd21dbce5d1e8b3041c4e786c3624 SHA512 fdfc2cde52baaac71683fbf31b6fe09f6bec81650842eb6b88dbc34d643142f73a89a935db028ab000d3fa33e1646b28558e398bb0eddba273f94e429e61a67d WHIRLPOOL 3980b333761185525d4f91caee6f850d086954c5f119b66827f3a1b4a91e85d35a302fad941139732d1e813d539172652beda5fe7776f78925a6d8fc33c4cf0b
diff --git a/games-simulation/planets/metadata.xml b/games-simulation/planets/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/planets/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/planets/planets-0.1.13.ebuild b/games-simulation/planets/planets-0.1.13.ebuild
new file mode 100644
index 000000000000..19f0eb25337b
--- /dev/null
+++ b/games-simulation/planets/planets-0.1.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="a simple interactive planetary system simulator"
+HOMEPAGE="http://planets.homedns.org/"
+SRC_URI="http://planets.homedns.org/dist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-lang/tk:0="
+DEPEND="${RDEPEND}
+ dev-lang/ocaml[tk]"
+
+src_install() {
+ dogamesbin planets
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+ dohtml getting_started.html
+ dodoc CHANGES CREDITS KEYBINDINGS.txt README TODO
+ prepgamesdirs
+}