summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-15 11:56:23 -0400
committerAaron Bauman <bman@gentoo.org>2020-05-17 11:54:36 -0400
commit5087a0903a02c31782f6070a24b876fc0b065f39 (patch)
treee6aec4204309e7be2fc67e0d2ea9ee4f1344ebf4 /gui-apps
parentgui-apps/wcm: wayfire config manager (diff)
downloadgentoo-5087a0903a02c31782f6070a24b876fc0b065f39.tar.gz
gentoo-5087a0903a02c31782f6070a24b876fc0b065f39.tar.bz2
gentoo-5087a0903a02c31782f6070a24b876fc0b065f39.zip
gui-apps/wf-shell: basic desktop shell for wayfire
Closes: https://bugs.gentoo.org/713880 a simple shell which showcases the capabilities of the wayfire window manager Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15050 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/metadata.xml18
-rw-r--r--gui-apps/wf-shell/wf-shell-0.4.0.ebuild49
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild49
4 files changed, 117 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
new file mode 100644
index 000000000000..e210eeae0b99
--- /dev/null
+++ b/gui-apps/wf-shell/Manifest
@@ -0,0 +1 @@
+DIST wf-shell-0.4.0.tar.xz 8996656 BLAKE2B 609668bcf00fcc7a0b8142d84a7101f07578c2d6a88616da286a615076372e5a356387cf5e3fdee9b4aba6f027d8d081a5cce32f7f00682a756d4ee9bc46916d SHA512 1b293ce3fc2b12acbadb75e0de28217ed24f733e26d7ad12ada9a5f0673df911e75eea5af6841c466f031151f881a8e36dda229ea4dc2f91825e2e6df42d4903
diff --git a/gui-apps/wf-shell/metadata.xml b/gui-apps/wf-shell/metadata.xml
new file mode 100644
index 000000000000..1f968932aa5f
--- /dev/null
+++ b/gui-apps/wf-shell/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Basic desktop environment for use with wayfire
+ which showcases all its plugins and desktop
+ effects. Integrates with other wayland
+ applications to provide a full desktop environment
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wf-shell/wf-shell-0.4.0.ebuild b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
new file mode 100644
index 000000000000..9167682d0b61
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio debug"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ ~gui-wm/wayfire-${PV}
+ >=gui-libs/gtk-layer-shell-0.1
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
new file mode 100644
index 000000000000..9167682d0b61
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio debug"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ ~gui-wm/wayfire-${PV}
+ >=gui-libs/gtk-layer-shell-0.1
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}