summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-24 13:10:25 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-24 13:10:25 -0600
commite91df20631445229ac7b0edb5e76d24bef29e0aa (patch)
treeeb536fa6b9561b54aa1a1565e4472086d9201d60 /gui-wm
parentgui-wm/sway: sync live (diff)
downloadgentoo-e91df20631445229ac7b0edb5e76d24bef29e0aa.tar.gz
gentoo-e91df20631445229ac7b0edb5e76d24bef29e0aa.tar.bz2
gentoo-e91df20631445229ac7b0edb5e76d24bef29e0aa.zip
gui-wm/sway: drop 1.9_rc4
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/Manifest1
-rw-r--r--gui-wm/sway/sway-1.9_rc4.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 01e87280a751..9bad0235366d 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,3 +1,2 @@
DIST sway-1.8.1.tar.gz 5577483 BLAKE2B 0e21c3a113b6bbb4a535ef77e347304ead98a424b65c176299f3d86fd52c35abf88d4e88fff0a8ecdb48494e8275110c79ea35fafd2902653db03fd938ee0323 SHA512 1f9909cb0402a99926d0ff1cefb98c40930e61678067413b6f195b036e6018a4f85bb3a6649d8bb743c93f0476b103791617a94d7c8c11a2c021f40131b65563
DIST sway-1.9.tar.gz 5581281 BLAKE2B 11d90866e3d12a76880f41e006be5ae7f3a3b1e6cbeb2412d30b673be91be7f60523dcce2892579e1da76de1d0498e0669138aa953bf1f595b97123720812e06 SHA512 7ec0a29078eb7e0fb1b6af97613c263adec78ddb03a63cb75fb5e44c7241ed144687fd094ee2eb70f4397832ca9bdffc88bc32dee7683bf0e515417c7a05d4c4
-DIST sway-1.9_rc4.tar.gz 5581376 BLAKE2B b871ec0b177eaeceb48b9da5266aaa60b8a27d0241ed497a1c5ea4aa08e105ec6604b53100243eba015bcd2a9620d508fde94921e460e6a940ef34d29680b5e7 SHA512 88298dd055d99ec1587c2fdf33199c4872eb6d51263cd967af36bf1db39e48a4f0dabcba47e2ff2e1f01f9062f24d189b3d0797c2ddf497691a7837976b07523
diff --git a/gui-wm/sway/sway-1.9_rc4.ebuild b/gui-wm/sway/sway-1.9_rc4.ebuild
deleted file mode 100644
index a3202673f8d0..000000000000
--- a/gui-wm/sway/sway-1.9_rc4.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson optfeature
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man +swaybar +swaynag tray wallpapers X"
-
-DEPEND="
- >=dev-libs/json-c-0.13:0=
- >=dev-libs/libinput-1.21.0:0=
- virtual/libudev
- sys-auth/seatd:=
- dev-libs/libpcre2
- >=dev-libs/wayland-1.20.0
- x11-libs/cairo
- >=x11-libs/libxkbcommon-1.5.0:0=
- x11-libs/pango
- x11-libs/pixman
- media-libs/mesa[gles2,libglvnd(+)]
- swaybar? ( x11-libs/gdk-pixbuf:2 )
- tray? ( || (
- sys-apps/systemd
- sys-auth/elogind
- sys-libs/basu
- ) )
- wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
- X? (
- x11-libs/libxcb:0=
- x11-libs/xcb-util-wm
- )
-"
-# x11-libs/xcb-util-wm needed for xcb-iccm
-if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[X?]"
-else
- DEPEND+="
- >=gui-libs/wlroots-0.17:=[X?]
- <gui-libs/wlroots-0.18:=[X?]
- "
-fi
-RDEPEND="
- x11-misc/xkeyboard-config
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- >=dev-build/meson-0.60.0
- virtual/pkgconfig
-"
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-REQUIRED_USE="tray? ( swaybar )"
-
-src_configure() {
- local emesonargs=(
- $(meson_feature man man-pages)
- $(meson_feature tray)
- $(meson_feature X xwayland)
- $(meson_feature swaybar gdk-pixbuf)
- $(meson_use swaynag)
- $(meson_use swaybar)
- $(meson_use wallpapers default-wallpaper)
- -Dfish-completions=true
- -Dzsh-completions=true
- -Dbash-completions=true
- )
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- insinto /usr/share/xdg-desktop-portal
- doins "${FILESDIR}/sway-portals.conf"
-}
-
-pkg_postinst() {
- optfeature_header "There are several packages that may be useful with sway:"
- optfeature "wallpaper utility" gui-apps/swaybg
- optfeature "idle management utility" gui-apps/swayidle
- optfeature "simple screen locker" gui-apps/swaylock
- optfeature "lightweight notification daemon" gui-apps/mako
- echo
- einfo "For a list of additional addons and tools usable with sway please"
- einfo "visit the offical wiki at:"
- einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
- einfo "Please note that some of them might not (yet) available on gentoo"
-}