summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 01:30:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:10:55 +0300
commit1f33dd1f0027a9e19536bff62dd8066e91bbf4cc (patch)
tree8ad67adc40f4fe853ff4ecf56a9ef926346ab716 /mate-base/mate-panel/mate-panel-1.22.0.ebuild
parentmate-base/caja: Version bump (v1.22.0) (diff)
downloadgentoo-1f33dd1f0027a9e19536bff62dd8066e91bbf4cc.tar.gz
gentoo-1f33dd1f0027a9e19536bff62dd8066e91bbf4cc.tar.bz2
gentoo-1f33dd1f0027a9e19536bff62dd8066e91bbf4cc.zip
mate-base/mate-panel: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mate-base/mate-panel/mate-panel-1.22.0.ebuild')
-rw-r--r--mate-base/mate-panel/mate-panel-1.22.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/mate-base/mate-panel/mate-panel-1.22.0.ebuild b/mate-base/mate-panel/mate-panel-1.22.0.ebuild
new file mode 100644
index 000000000000..0243a59e92ad
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.10.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.0:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_with X x) \
+ $(use_enable introspection)
+}