summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-09 19:06:04 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-09 19:09:40 +0100
commit30d896b31ad2e5725469f02e932b0362b9f13397 (patch)
treeccdc353eaed134209ac945331cab2e210131c5fe /media-libs/sbc/sbc-1.5.ebuild
parentnet-mail/b4: bump to 0.6.1 (diff)
downloadgentoo-30d896b31ad2e5725469f02e932b0362b9f13397.tar.gz
gentoo-30d896b31ad2e5725469f02e932b0362b9f13397.tar.bz2
gentoo-30d896b31ad2e5725469f02e932b0362b9f13397.zip
media-libs/sbc: Bump to 1.5
Thanks-to: Joakim Tjernlund Closes: https://bugs.gentoo.org/759073 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/sbc/sbc-1.5.ebuild')
-rw-r--r--media-libs/sbc/sbc-1.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/sbc/sbc-1.5.ebuild b/media-libs/sbc/sbc-1.5.ebuild
new file mode 100644
index 000000000000..65d68e49819c
--- /dev/null
+++ b/media-libs/sbc/sbc-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="Audio codec to connect bluetooth HQ audio devices as headphones or loudspeakers"
+HOMEPAGE="https://git.kernel.org/?p=bluetooth/sbc.git"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}