summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-05-03 20:40:27 +0300
committerMart Raudsepp <leio@gentoo.org>2020-05-03 22:12:05 +0300
commit3293300c2b17e60209213dc9fef2eec3569635ed (patch)
tree95ac29f060e09b5b36a6e3e0ae85767f53601db8 /media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
parentmedia-plugins/gst-plugins-gdkpixbuf: bump to 1.16.2 (diff)
downloadgentoo-3293300c2b17e60209213dc9fef2eec3569635ed.tar.gz
gentoo-3293300c2b17e60209213dc9fef2eec3569635ed.tar.bz2
gentoo-3293300c2b17e60209213dc9fef2eec3569635ed.zip
media-plugins/gst-plugins-gtk: bump to 1.16.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild')
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
new file mode 100644
index 000000000000..1b37803b64ac
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"