summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gnac/gnac-0.2.4.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gnac/gnac-0.2.4.1.ebuild')
-rw-r--r--media-sound/gnac/gnac-0.2.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/gnac/gnac-0.2.4.1.ebuild b/media-sound/gnac/gnac-0.2.4.1.ebuild
new file mode 100644
index 000000000000..6ee40a00f04e
--- /dev/null
+++ b/media-sound/gnac/gnac-0.2.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools gnome2
+
+DESCRIPTION="Audio converter for GNOME"
+HOMEPAGE="http://gnac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnac/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LANGS=" cs da de en_GB es gl fr he hu it lt nb pt_BR pl ro ru sl sv te tr zh_CN"
+IUSE="aac flac libnotify mp3 nls wavpack ${LANGS// / linguas_}"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-libs/libunique:3
+ dev-libs/libxml2:2
+ libnotify? ( x11-libs/libnotify )
+ >=media-libs/gstreamer-0.10.31:0.10
+ >=media-libs/gst-plugins-base-0.10.31:0.10
+ media-plugins/gst-plugins-gio:0.10
+ media-plugins/gst-plugins-meta:0.10[flac?,mp3?,wavpack?]
+ aac? ( media-plugins/gst-plugins-faac:0.10 )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.17.2
+ gnome-base/gnome-common
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable nls)
+}