summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gnac/gnac-0.2.4.1.ebuild')
-rw-r--r--media-sound/gnac/gnac-0.2.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/gnac/gnac-0.2.4.1.ebuild b/media-sound/gnac/gnac-0.2.4.1.ebuild
new file mode 100644
index 000000000000..6ee40a00f04e
--- /dev/null
+++ b/media-sound/gnac/gnac-0.2.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools gnome2
+
+DESCRIPTION="Audio converter for GNOME"
+HOMEPAGE="http://gnac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnac/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LANGS=" cs da de en_GB es gl fr he hu it lt nb pt_BR pl ro ru sl sv te tr zh_CN"
+IUSE="aac flac libnotify mp3 nls wavpack ${LANGS// / linguas_}"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-libs/libunique:3
+ dev-libs/libxml2:2
+ libnotify? ( x11-libs/libnotify )
+ >=media-libs/gstreamer-0.10.31:0.10
+ >=media-libs/gst-plugins-base-0.10.31:0.10
+ media-plugins/gst-plugins-gio:0.10
+ media-plugins/gst-plugins-meta:0.10[flac?,mp3?,wavpack?]
+ aac? ( media-plugins/gst-plugins-faac:0.10 )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.17.2
+ gnome-base/gnome-common
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable nls)
+}