summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-26 14:20:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-26 14:50:39 +0200
commit20c0969abc918f14a74b0586556a1fb5f9181be7 (patch)
tree3e5cff6dc6a427993eb8f4c19cc83ccbffab08a6 /media-video/ffmpeg2theora
parentdev-util/scons: Port to py3.9 (diff)
downloadgentoo-20c0969abc918f14a74b0586556a1fb5f9181be7.tar.gz
gentoo-20c0969abc918f14a74b0586556a1fb5f9181be7.tar.bz2
gentoo-20c0969abc918f14a74b0586556a1fb5f9181be7.zip
media-video/ffmpeg2theora: Port to py3
Closes: https://bugs.gentoo.org/735546 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg2theora')
-rw-r--r--media-video/ffmpeg2theora/ffmpeg2theora-0.30-r1.ebuild (renamed from media-video/ffmpeg2theora/ffmpeg2theora-0.30.ebuild)27
-rw-r--r--media-video/ffmpeg2theora/files/ffmpeg2theora-0.29-underlinking.patch4
2 files changed, 19 insertions, 12 deletions
diff --git a/media-video/ffmpeg2theora/ffmpeg2theora-0.30.ebuild b/media-video/ffmpeg2theora/ffmpeg2theora-0.30-r1.ebuild
index 49c6e4674e0a..0e9cd2e06d01 100644
--- a/media-video/ffmpeg2theora/ffmpeg2theora-0.30.ebuild
+++ b/media-video/ffmpeg2theora/ffmpeg2theora-0.30-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs scons-utils
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-any-r1 scons-utils toolchain-funcs
DESCRIPTION="A simple converter to create Ogg Theora files"
HOMEPAGE="http://www.v2v.cc/~j/ffmpeg2theora/"
@@ -19,30 +21,35 @@ RDEPEND="
>=media-libs/libogg-1.1
>=media-libs/libtheora-1.1[encode]
kate? ( >=media-libs/libkate-0.3.7 )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.29-swr.patch
+ "${FILESDIR}"/${PN}-0.29-underlinking.patch
+)
+
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.29-swr.patch \
- "${FILESDIR}"/${PN}-0.29-underlinking.patch
+ default
+ 2to3 -n -w --no-diffs SConstruct || die
}
src_configure() {
- myesconsargs=(
+ SCONSARGS=(
APPEND_CCFLAGS="${CFLAGS}"
APPEND_LINKFLAGS="${LDFLAGS}"
prefix=/usr
mandir=PREFIX/share/man
libkate=$(usex kate 1 0)
- )
+ )
}
src_compile() {
- escons
+ escons "${SCONSARGS[@]}"
}
src_install() {
- escons destdir="${D}" install
+ escons "${SCONSARGS[@]}" destdir="${D}" install
dodoc AUTHORS ChangeLog README subtitles.txt TODO
}
diff --git a/media-video/ffmpeg2theora/files/ffmpeg2theora-0.29-underlinking.patch b/media-video/ffmpeg2theora/files/ffmpeg2theora-0.29-underlinking.patch
index dc877603913a..791e39d87744 100644
--- a/media-video/ffmpeg2theora/files/ffmpeg2theora-0.29-underlinking.patch
+++ b/media-video/ffmpeg2theora/files/ffmpeg2theora-0.29-underlinking.patch
@@ -6,8 +6,8 @@ v = pow(v, g) * 255.0; // mplayer's vf_eq2.c multiplies with 256 here, strang
For build failure and log, see Gentoo bug #504698
---- SConstruct
-+++ SConstruct
+--- a/SConstruct
++++ b/SConstruct
@@ -206,9 +206,8 @@
if env['crossmingw']:
env.Append(CCFLAGS=['-Wl,-subsystem,windows'])