summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 13:42:54 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 13:42:54 +0100
commit53d9d8131a66a49878ed04a97947b14229065bd8 (patch)
treef48cd931089450ab1610dd9a3fff4bcfc5d51b1f /media-video
parentmedia-sound/dvda-author: Port to EAPI 7 (diff)
downloadgentoo-53d9d8131a66a49878ed04a97947b14229065bd8.tar.gz
gentoo-53d9d8131a66a49878ed04a97947b14229065bd8.tar.bz2
gentoo-53d9d8131a66a49878ed04a97947b14229065bd8.zip
media-video/frameworks: Port to EAPI 7
Closes: https://bugs.gentoo.org/706710 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/frameworks/files/frameworks-0.3.7-fno-common.patch63
-rw-r--r--media-video/frameworks/frameworks-0.3.7-r1.ebuild26
2 files changed, 74 insertions, 15 deletions
diff --git a/media-video/frameworks/files/frameworks-0.3.7-fno-common.patch b/media-video/frameworks/files/frameworks-0.3.7-fno-common.patch
new file mode 100644
index 000000000000..09e05d5ae441
--- /dev/null
+++ b/media-video/frameworks/files/frameworks-0.3.7-fno-common.patch
@@ -0,0 +1,63 @@
+--- a/src/callbacks.c
++++ b/src/callbacks.c
+@@ -1,5 +1,7 @@
+ #include "common.h"
+
++extern gboolean fwks_quit;
++
+ void on_main_window_delete(GtkWidget *widget, GdkEvent *event, struct Interface *interface)
+ {
+ frameworks_interface_quit(interface);
+--- a/src/camera.c
++++ b/src/camera.c
+@@ -1,6 +1,8 @@
+ #include <math.h>
+ #include "common.h"
+
++extern gboolean fwks_quit;
++
+ /* internal function prototypes */
+ gpointer read_thread(gpointer data);
+ void reset_buffer(struct Camera *camera, struct RawBuf *buf);
+--- a/src/colorspace.c
++++ b/src/colorspace.c
+@@ -14,7 +14,7 @@
+ #define BGR24_R(start) start+2
+
+ /* Global vars */
+-gint force_palette;
++extern gint force_palette;
+
+ void
+ compose_yuv_to_rgb(guint8 y, gint32 ug, gint32 ub, gint32 vg, gint32 vr,
+--- a/src/common.h
++++ b/src/common.h
+@@ -42,4 +42,5 @@
+ #include "frameworks.h"
+
+ /* global vars */
+-gboolean fwks_quit;
++extern gboolean fwks_quit;
++extern gint force_palette;
+--- a/src/frameworks.c
++++ b/src/frameworks.c
+@@ -32,7 +32,7 @@ gboolean fwks_quit = FALSE;
+
+ /* Hack to allow forcing of palette for webcams that lie about their paletter
+ * (or more likely bugs in frameworks decode the thing wrong... */
+-gint force_palette = -1;
++extern gint force_palette = -1;
+
+ int main(int argc, char *argv[])
+ {
+--- a/src/interface.c
++++ b/src/interface.c
+@@ -9,6 +9,8 @@
+ #define FWKS_OVERLAY_OPACITY 60 /* between 0..255, the opacity of the overlays */
+ #define FWKS_OPACITY_FULL 255 /* full opacity */
+
++extern gboolean fwks_quit;
++
+ gpointer test_thread(gpointer data);
+
+ gpointer display_thread(gpointer data);
diff --git a/media-video/frameworks/frameworks-0.3.7-r1.ebuild b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
index 32b2c372bb81..bc2a76ae9d4e 100644
--- a/media-video/frameworks/frameworks-0.3.7-r1.ebuild
+++ b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
DESCRIPTION="A small v4l frame capture utility especially suited for stop motion animation"
SRC_URI="http://frameworks.polycrystal.org/release/${P}.tar.gz"
HOMEPAGE="http://frameworks.polycrystal.org"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="
>=gnome-base/libglade-2
- x11-libs/gtk+:2
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS=(
- AUTHORS ChangeLog NEWS README TODO
-)
PATCHES=(
- "${FILESDIR}"/${PN}-0.3.7-ceilf.patch
- "${FILESDIR}"/${PN}-0.3.7-strcmp-and-datadir.patch
+ "${FILESDIR}"/${P}-ceilf.patch
+ "${FILESDIR}"/${P}-strcmp-and-datadir.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
default
-
+ mv configure.{in,ac} || die
eautoreconf
}