summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-04-22 17:33:58 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-01 11:26:38 +0200
commitc1fecceec0e9a6dd1880120a40d59bad0cf56523 (patch)
treedc2e3640e80fecfbda9cb67924410b3a3573a5d8 /net-analyzer/bro
parentdev-perl/Bio-DB-HTS: allow explicit specification of htslib directories (diff)
downloadgentoo-c1fecceec0e9a6dd1880120a40d59bad0cf56523.tar.gz
gentoo-c1fecceec0e9a6dd1880120a40d59bad0cf56523.tar.bz2
gentoo-c1fecceec0e9a6dd1880120a40d59bad0cf56523.zip
net-analyzer/bro: fix python shebang #600266
Package-Manager: Portage-2.3.31, Repoman-2.3.9 Closes: https://bugs.gentoo.org/600266 Closes: https://github.com/gentoo/gentoo/pull/8107
Diffstat (limited to 'net-analyzer/bro')
-rw-r--r--net-analyzer/bro/bro-2.4.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-analyzer/bro/bro-2.4.1-r2.ebuild b/net-analyzer/bro/bro-2.4.1-r2.ebuild
index 231ad94155e5..5170d3b253a6 100644
--- a/net-analyzer/bro/bro-2.4.1-r2.ebuild
+++ b/net-analyzer/bro/bro-2.4.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,6 +44,12 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ # Disable shell script feature which sets interpreter to build time default
+ find . -name "*.cmake" -exec sed -i -e "s:\${\${_shell}_interp}:/usr/bin/env ${EPYTHON}:g" {} + || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_DEBUG=$(usex debug true false)