summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nessus-plugins/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nessus-plugins/files')
-rw-r--r--net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch b/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch
new file mode 100644
index 000000000000..39366844382f
--- /dev/null
+++ b/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch
@@ -0,0 +1,58 @@
+ plugins/find_service/Makefile | 2 +-
+ plugins/nessus_tcp_scanner/Makefile | 2 +-
+ plugins/ssl_ciphers/Makefile | 2 +-
+ plugins/synscan/Makefile | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/plugins/find_service/Makefile b/plugins/find_service/Makefile
+index f4fd8e3..12e62a3 100644
+--- a/plugins/find_service/Makefile
++++ b/plugins/find_service/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=find_service
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/nessus_tcp_scanner/Makefile b/plugins/nessus_tcp_scanner/Makefile
+index 8cf6c6d..7a27495 100644
+--- a/plugins/nessus_tcp_scanner/Makefile
++++ b/plugins/nessus_tcp_scanner/Makefile
+@@ -8,7 +8,7 @@ PLUGNAME=nessus_tcp_scanner
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) -lm $(LIBUTIL) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) -lm $(LIBUTIL) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/ssl_ciphers/Makefile b/plugins/ssl_ciphers/Makefile
+index dc10e64..1747745 100644
+--- a/plugins/ssl_ciphers/Makefile
++++ b/plugins/ssl_ciphers/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=ssl_ciphers
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/synscan/Makefile b/plugins/synscan/Makefile
+index 16aefa1..c434b92 100644
+--- a/plugins/synscan/Makefile
++++ b/plugins/synscan/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=synscan
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(DEFS) $(LDFLAGS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :