summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 15:07:12 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commit919012ef6bffd81b330e53f015223f269b0872f6 (patch)
tree87fbe885b999acfbc7d18e245a4240f6dfcb5051 /net-dialup
parentinet-dialup/capifwd: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-919012ef6bffd81b330e53f015223f269b0872f6.tar.gz
gentoo-919012ef6bffd81b330e53f015223f269b0872f6.tar.bz2
gentoo-919012ef6bffd81b330e53f015223f269b0872f6.zip
net-dialup/cistronradius: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/cistronradius/cistronradius-1.6.8-r2.ebuild49
-rw-r--r--net-dialup/cistronradius/files/cistronradius.rc4
2 files changed, 51 insertions, 2 deletions
diff --git a/net-dialup/cistronradius/cistronradius-1.6.8-r2.ebuild b/net-dialup/cistronradius/cistronradius-1.6.8-r2.ebuild
new file mode 100644
index 000000000000..5461d001eae9
--- /dev/null
+++ b/net-dialup/cistronradius/cistronradius-1.6.8-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Authentication and accounting server for terminal servers that speak the RADIUS protocol"
+HOMEPAGE="http://www.radius.cistron.nl/"
+SRC_URI="ftp://ftp.radius.cistron.nl/pub/radius/radiusd-cistron-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND="
+ !net-dialup/freeradius
+ !net-dialup/gnuradius"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/radiusd-cistron-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+ sed -i -e "s:SHAREDIR/::g" raddb/dictionary || die
+ mv src/checkrad.pl src/checkrad || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake -C src \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ BINDIR=/usr/bin SBINDIR=/usr/sbin \
+ MANDIR=/usr/share/man SHAREDIR=/usr/share/radius
+}
+
+src_install() {
+ insinto /etc/raddb
+ doins raddb/*
+ dodoc README doc/{ChangeLog,FAQ.txt,README*}
+ doman doc/{*.1,*.8,*.5rad,*.8rad}
+
+ dosbin src/{checkrad,radiusd,radrelay}
+ dobin src/{radclient,radlast,radtest,radwho,radzap}
+
+ newinitd "${FILESDIR}/cistronradius.rc" cistronradius
+}
diff --git a/net-dialup/cistronradius/files/cistronradius.rc b/net-dialup/cistronradius/files/cistronradius.rc
index cc4b7d3deb9e..3154c6affdc8 100644
--- a/net-dialup/cistronradius/files/cistronradius.rc
+++ b/net-dialup/cistronradius/files/cistronradius.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$