summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenko (SpiderX) <spiderx@spiderx.dp.ua>2016-09-16 16:02:04 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-09-27 22:23:30 +0200
commite780cced313278807c053656e1baa3f721c5e006 (patch)
tree5a9f01ff4ea07b74ff088ef7121d18dea8c41054 /net-im/slack-bin/slack-bin-2.1.2.ebuild
parentapp-admin/yadm: version bump to 1.05. (diff)
downloadgentoo-e780cced313278807c053656e1baa3f721c5e006.tar.gz
gentoo-e780cced313278807c053656e1baa3f721c5e006.tar.bz2
gentoo-e780cced313278807c053656e1baa3f721c5e006.zip
net-im/slack-bin: new package.
Slack is a cloud-based team collaboration tool. It offers persistent chat rooms (channels) organized by topic, as well as private groups and direct messaging. All content (files, conversations, people) inside Slack is searchable. Slack integrates with a large number of third-party services and supports community-built integrations. Base for ebuild from https://github.com/SpiderX/portage-overlay/tree/master/net-im/slack-bin. Gentoo-Bug: https://bugs.gentoo.org/575786 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2342 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-im/slack-bin/slack-bin-2.1.2.ebuild')
-rw-r--r--net-im/slack-bin/slack-bin-2.1.2.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-im/slack-bin/slack-bin-2.1.2.ebuild b/net-im/slack-bin/slack-bin-2.1.2.ebuild
new file mode 100644
index 000000000000..3f3e8eb110bf
--- /dev/null
+++ b/net-im/slack-bin/slack-bin-2.1.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit unpacker gnome2-utils
+
+QA_PREBUILT="
+ opt/slack/slack
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/libnode.so
+ opt/slack/libgcrypt.so.11
+ opt/slack/libffmpeg.so
+ opt/slack/libCallsCore.so
+"
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="http://www.slack.com/"
+
+MY_PN="${PN/-bin/}"
+BASE_URI="https://downloads.slack-edge.com/linux_releases/${MY_PN}-desktop-${PV}-_arch_.deb"
+
+SRC_URI="
+ x86? ( ${BASE_URI/_arch_/i386} )
+ amd64? ( ${BASE_URI/_arch_/amd64} )
+"
+
+LICENSE="MIT Apache-2.0 BSD ISC LGPL-2 AFL-2.1 public-domain WTFPL-2 Artistic-2 no-source-code"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-libs/cairo[xcb]
+ media-libs/alsa-lib
+ media-libs/harfbuzz[graphite]
+ media-libs/libcanberra[gtk]
+ dev-libs/nss
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome-keyring
+ gnome-base/gconf:2
+ sys-apps/dbus
+ net-print/cups[ssl]
+ net-misc/curl
+ virtual/udev
+ virtual/libc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+src_install() {
+ insinto /usr/share/pixmaps
+ doins usr/share/pixmaps/${MY_PN}.png
+
+ newicon -s 512 usr/share/pixmaps/${MY_PN}.png ${MY_PN}.png
+ domenu usr/share/applications/${MY_PN}.desktop
+
+ insinto /opt/${MY_PN}
+ doins -r usr/lib/${MY_PN}/*
+ fperms +x /opt/${MY_PN}/${MY_PN}
+ dosym /opt/${MY_PN}/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}