summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-09 19:49:39 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-09 19:49:39 +0100
commitd6abd790f7931624d968f6a2e74e9e358ddcfee1 (patch)
tree5d7979370528774e4da6699e28f5c340cfc37ed0 /net-libs
parentnet-libs/meanwhile: Port to EAPI 7 (diff)
downloadgentoo-d6abd790f7931624d968f6a2e74e9e358ddcfee1.tar.gz
gentoo-d6abd790f7931624d968f6a2e74e9e358ddcfee1.tar.bz2
gentoo-d6abd790f7931624d968f6a2e74e9e358ddcfee1.zip
net-libs/librouteros: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch (renamed from net-libs/librouteros/files/disable_werror.patch)4
-rw-r--r--net-libs/librouteros/librouteros-1.1.2.ebuild30
2 files changed, 22 insertions, 12 deletions
diff --git a/net-libs/librouteros/files/disable_werror.patch b/net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch
index 599e85b74d00..b3f005a4be3a 100644
--- a/net-libs/librouteros/files/disable_werror.patch
+++ b/net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch
@@ -1,5 +1,5 @@
---- src/Makefile.am.orig 2011-12-30 21:17:04.233158203 +0200
-+++ src/Makefile.am 2011-12-30 21:18:42.186354842 +0200
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = foreign no-dependencies
diff --git a/net-libs/librouteros/librouteros-1.1.2.ebuild b/net-libs/librouteros/librouteros-1.1.2.ebuild
index 9e89899c90e7..a6be5fce2804 100644
--- a/net-libs/librouteros/librouteros-1.1.2.ebuild
+++ b/net-libs/librouteros/librouteros-1.1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit base autotools-utils autotools
+inherit autotools
DESCRIPTION="Library for accessing MikroTik's RouterOS via its API"
HOMEPAGE="http://verplant.org/librouteros/"
@@ -12,15 +12,25 @@ SRC_URI="http://verplant.org/librouteros/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug static-libs"
+IUSE="debug"
-DEPEND="dev-libs/libgcrypt:0"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}"
-DOCS=(README AUTHORS)
-PATCHES=("${FILESDIR}"/disable_werror.patch)
+PATCHES=( "${FILESDIR}"/${P}-remove-Werror.patch )
-src_prepare(){
- base_src_prepare
+src_prepare() {
+ default
eautoreconf
}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}